WordPress 4.8.2 Security & Maintenance Release

by Craig Harffey | September 20, 2017

A new security release has been published for WordPress to fix security issues discovered in WordPress 4.8.1 and earlier.

We encourage all users of WordPress to upgrade.

If you have any questions or need any assistance to do this, simply go to our ServiceDesk

Clients with an existing site management subscription will be automatically upgraded – no action is required.

For more details see the WordPress Website